Sinclair ZX81 ULA Fix

For discussion of proposed projects which we would like to see get off the ground and offers of help
Post Reply
RWAP
Site Admin
Posts: 167
Joined: Sat Jan 12, 2008 4:02 pm
What is the middle number (10): 9
Location: Staffordshire, UK
Contact:

Sinclair ZX81 ULA Fix

Post by RWAP » Thu Jan 20, 2011 11:17 pm

Many Sinclair ZX81 home computers suffer with a problem when trying to use them on a modern TV - namely a black cursor on a very dark grey screen, making it next to impossible to view the ZX81's output. This was fixed on the later version of the ZX81 ULA chip, but it is rare to find ZX81s with that updated ULA, and if you can find a spare ULA, they are normally soldered directly onto the ZX81 motherboard, making it difficult to replace.

We are currently working on producing a small board which will fit within the Sinclair ZX81 case, and provide the missing latch - the board will need to be connected to two wires on the ZX81 motherboard, making it quite a straight forward matter of installation.
Rich Mellor
RWAP Services
http://www.rwapsoftware.co.uk
http://www.rwapadventures.com

Supporting the Sinclair Retro Computing Scene

RWAP
Site Admin
Posts: 167
Joined: Sat Jan 12, 2008 4:02 pm
What is the middle number (10): 9
Location: Staffordshire, UK
Contact:

Re: Sinclair ZX81 ULA Fix

Post by RWAP » Fri Nov 04, 2011 6:52 am

We have now released this fix as the ZXvid - see http://rwapadventures.com/forums/viewtopic.php?f=6&t=69 for more details
Rich Mellor
RWAP Services
http://www.rwapsoftware.co.uk
http://www.rwapadventures.com

Supporting the Sinclair Retro Computing Scene

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest